Migrate FusionDirectory from 1.0.18 to 1.0.19

Ubuntu 12.0.4 TLS users

Warning

Since 1.0.9.2 FusionDirectory need the php-cas library for CAS server support. This library can normally found in universe in the Ubuntu repositories.

In case you did not find it, grab the deb from here and install it

http://packages.ubuntu.com/trusty/all/php-cas/download

and select your preferred mirror

Upgrade FusionDirectory first

Upgrade FusionDirectory core package before other ones to avoid dependencies errors:

apt-get install fusiondirectory

Upgrade FusionDirectory schema package too.

apt-get install fusiondirectory-schema

Upgrade of LDAP directory

No upgrade

Upgrade of LDAP directory

No Upgrade

Correcting acl editownpwd

Warning

To fix the error in the installed editownpwd, you need to go :

  • Acl roles
  • Open the editownpwd acl
  • Save it

Its very important you do it, to know why look at the users must update his role editownpasswd

Enjoy :)